ejdb2_flutter 2.0.581
ejdb2_flutter: ^2.0.581 copied to clipboard

Embeddable JSON Database engine EJDB http://ejdb.org Flutter binding.

4
likes
80 / 110
pub points
40 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 36 out of 80 API elements (45.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:ejdb2_flutter/ejdb2_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The declaration '_fromList' isn't referenced.

lib/ejdb2_flutter.dart:129:9

    ╷
129 │   JBDOC._fromList(List list) : this(list[0] as int, list[1] as String);
    │         ^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/ejdb2_flutter.dart

INFO: A value of type 'Future

lib/ejdb2_flutter.dart:401:14

    ╷
401 │       return Future.error(err);
    │              ^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/ejdb2_flutter.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
json_at^1.0.41.0.41.0.4
pedantic^1.8.0+11.11.01.11.0
quiver^2.0.52.1.53.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-20.0.020.0.0
analyzer-1.4.01.4.0
args-2.0.02.0.0
async-2.5.02.5.0
boolean_selector-2.1.02.1.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
coverage-1.0.21.0.2
crypto-3.0.13.0.1
file-6.1.06.1.0
glob-2.0.12.0.1
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
io-1.0.01.0.0
js-0.6.30.6.3
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-1.0.01.0.0
node_preamble-2.0.02.0.0
package_config-2.0.02.0.0
path-1.8.01.8.0
pool-1.5.01.5.0
pub_semver-2.0.02.0.0
shelf-1.1.01.1.0
shelf_packages_handler-3.0.03.0.0
shelf_static-1.0.01.0.0
shelf_web_socket-1.0.11.0.1
sky_engine-0.0.990.0.99
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test-1.16.81.16.8
test_api-0.3.00.3.0
test_core-0.3.190.3.19
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
vm_service-6.2.06.2.0
watcher-1.0.01.0.0
web_socket_channel-2.0.02.0.0
webkit_inspection_protocol-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.5` on quiver does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

4
likes
80
pub points
40%
popularity

Publisher

ejdb.org

Embeddable JSON Database engine EJDB http://ejdb.org Flutter binding.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, json_at, pedantic, quiver

More

Packages that depend on ejdb2_flutter