easy_tui 3.3.1
easy_tui: ^3.3.1 copied to clipboard

Very simple tool to generate menus for gathering user input.

2
likes
80 / 130
pub points
0 %
popularity

We analyzed this package on May 12, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • Homepage URL isn't helpful.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 43 out of 64 API elements (67.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:easy_tui/cli/io/in/terminal_input.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/tui/text_form_ui.dart:52:34

   ╷
52 │     final List<String> answers = List<String>(frozenQuestions.length);
   │                                  ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/tui/text_form_ui.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/tui/text_ui.dart:30:19

   ╷
30 │     this._lines = List<String>();
   │                   ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/tui/text_ui.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.1.71.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

2
likes
80
pub points
0%
popularity

Very simple tool to generate menus for gathering user input.

Homepage
Repository (GitLab)
View/report issues

Documentation

API reference

Uploader

code.iron.e@gmail.com

License

GPL 3.0 (LICENSE)

Dependencies

meta

More

Packages that depend on easy_tui