easy_router 0.9.4
easy_router: ^0.9.4 copied to clipboard

一个简单的路由器框架

0
likes
70 / 130
pub points
8 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 11 API elements (36.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/easy_router.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/builder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
mustache4dart^3.0.0-dev.1.03.0.0-dev.1.03.0.0-dev.1.0
source_gen^0.9.4+40.9.10+21.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.023.0.0
analyzer-0.41.12.0.0
args-1.6.02.2.0
async-2.8.12.8.1
build-1.6.22.0.3
build_config-0.4.51.0.0
build_daemon-2.1.103.0.0
build_resolvers-1.5.32.0.4
build_runner-1.11.12.0.6
build_runner_core-6.1.77.0.1
built_collection-5.1.05.1.0
built_value-8.1.18.1.1
characters-1.1.01.1.0
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.3
clock-1.1.01.1.0
code_builder-3.7.04.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
dart_style-1.3.122.0.3
file-5.2.16.1.2
fixnum-1.0.01.0.0
glob-1.2.02.0.1
graphs-0.2.02.0.0
http_multi_server-2.2.03.0.1
http_parser-4.0.04.0.0
intl-0.17.00.17.0
io-0.3.51.0.3
js-0.6.30.6.3
json_annotation-4.0.14.1.0
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.3.01.7.0
mime-1.0.01.0.0
node_interop-1.2.12.0.2
node_io-1.2.02.1.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pool-1.5.01.5.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
reflectable-2.2.93.0.2
shelf-1.2.01.2.0
shelf_web_socket-0.2.4+11.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-0.1.1+31.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
watcher-0.9.7+151.0.0
web_socket_channel-1.2.02.1.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.9.4+4` on source_gen does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions source_gen to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.3, Dart 2.13.4.