easy_prefs_gen 0.0.1 icon indicating copy to clipboard operation
easy_prefs_gen: ^0.0.1 copied to clipboard

SDKDart

Code Generation for shared_preferences

0
likes
60/ 130
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 60 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 18 API elements (5.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:easy_prefs_gen/generator_registration.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:easy_prefs_gen/generator_registration.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:easy_prefs_gen/generator_registration.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:easy_prefs_gen/generator_registration.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:easy_prefs_gen/generator_registration.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:easy_prefs_gen/generator_registration.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/generator_registration.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/prefs_generator.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^3.3.13.4.14.1.0
build^2.2.12.3.02.3.0
easy_prefs^0.0.10.0.10.0.1
source_gen^1.2.11.2.21.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-38.0.040.0.0
args-2.3.12.3.1
async-2.9.02.9.0
collection-1.16.01.16.0
convert-3.0.23.0.2
crypto-3.0.23.0.2
dart_style-2.2.32.2.3
file-6.1.26.1.2
glob-2.1.02.1.0
logging-1.0.21.0.2
meta-1.8.01.8.0
package_config-2.1.02.1.0
path-1.8.21.8.2
pub_semver-2.1.12.1.1
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.11.0.1
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.3.1` on analyzer does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Dart 2.17.5.