easy_localization_sheet 1.0.3 copy "easy_localization_sheet: ^1.0.3" to clipboard
easy_localization_sheet: ^1.0.3 copied to clipboard

A tool to help generate json from csv file. It is useful when used with localization packages.

3
likes
150/ 160
pub points
38%
popularity

We analyzed this package 3 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

0 out of 0 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux
  • ✓ macOS
  • ✓ Windows

These platforms are not supported:

Android

Cannot assign Android automatically to a binary only package.

iOS

Cannot assign iOS automatically to a binary only package.

Web

Cannot assign Web automatically to a binary only package.

OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
csv ^5.0.2 5.1.1 6.0.0
path ^1.8.3 1.9.0 1.9.0
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.2` on csv does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions csv to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

3
likes
150
pub points
38%
popularity

Publisher

unverified uploader

A tool to help generate json from csv file. It is useful when used with localization packages.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

csv, path, yaml

More

Packages that depend on easy_localization_sheet