easy_blocs 0.0.1+2

  • Readme
  • Changelog
  • Example
  • Installing
  • 14

easy_blocs #

A new Flutter project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1+1] - 2019-05-24

  • Add PageConnector

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  easy_blocs: ^0.0.1+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:easy_blocs/easy_blocs.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
13
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
14
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Fix lib/src/rxdart_cache/CacheSubject.dart. (-68.36 points)

Analysis of lib/src/rxdart_cache/CacheSubject.dart failed with 4 errors:

line 47 col 7: Undefined class 'Observable'.

line 70 col 7: The method 'Observable' isn't defined for the class 'CacheSubject'.

line 100 col 26: 'CacheSubject.stream' ('CacheObservable

line 100 col 26: 'CacheSubject.stream' ('CacheObservable

Fix lib/src/rxdart_cache/CacheObservable.dart. (-44.03 points)

Analysis of lib/src/rxdart_cache/CacheObservable.dart failed with 2 errors, 1 hint:

line 5 col 46: Classes and mixins can only implement other classes and mixins.

line 5 col 46: Undefined class 'Observable'.

line 1 col 8: Unused import: 'package:rxdart/rxdart.dart'.

Fix lib/src/rxdart_cache/CacheStreamBuilder.dart. (-25 points)

Analysis of lib/src/rxdart_cache/CacheStreamBuilder.dart failed with 1 error:

line 18 col 25: The argument type 'CacheObservable

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/Provider.dart (Run flutter format to format lib/src/Provider.dart.)
  • lib/src/connector/PageConnector.dart (Run flutter format to format lib/src/connector/PageConnector.dart.)
  • lib/src/translator/Translator.dart (Run flutter format to format lib/src/translator/Translator.dart.)
  • lib/src/translator/Widgets.dart (Run flutter format to format lib/src/translator/Widgets.dart.)

Maintenance issues and suggestions

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 4 dependencies without version constraints. Specify version ranges for the following dependencies: dash, easy_widget, rxdart, shared_preferences.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
dash any 0.5.6
easy_widget any 0.0.1+16
flutter 0.0.0
rxdart any 0.23.1
shared_preferences any 0.5.6
Transitive dependencies
after_layout 1.0.7+2
collection 1.14.11 1.14.12
flutter_page_indicator 0.0.3
flutter_swiper 1.1.6
flutter_web_plugins 0.0.0
meta 1.1.8
photo_view 0.9.1
rubber 0.4.0
shared_preferences_macos 0.0.1+3
shared_preferences_platform_interface 1.0.1
shared_preferences_web 0.1.2+2
sky_engine 0.0.99
transformer_page_view 0.1.6
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner any
dash_generator any
flutter_test