easy_widget 0.0.1+16

easy_packages #

A new Flutter project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1+15] 2019-05-27

  • Fixed FlagView

[0.0.1+9] 2019-05-27

  • Fixed RubberConcierge

[0.0.1+8] 2019-05-27

  • Update icon in RubberConcierge

[0.0.1+7] 2019-05-26

  • Add PrimaryRubberController in Rubber.dart

[0.0.1+6] 2019-05-26

  • Add Rubber.dart & SliverListSeparatorDelegate.dart & Papyrus.dart


  • Add ListViewSeparated


  • Fixed factory method ProgressTabBar.number

[0.0.1] - TODO: Add release date.

  • Initial release.


example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  easy_widget: ^0.0.1+16

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:easy_widget/easy_widget.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Sep 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/src/gallery.dart. (-25 points)

Analysis of lib/src/gallery.dart failed with 1 error:

line 83 col 15: The named parameter 'heroTag' isn't defined.

Fix lib/src/easy_image.dart. (-0.50 points)

Analysis of lib/src/easy_image.dart reported 1 hint:

line 92 col 3: This function has a return type of 'Widget', but doesn't end with a return statement.

Format lib/easy_widget.dart.

Run flutter format to format lib/easy_widget.dart.

Fix additional 17 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/FlagView.dart (Run flutter format to format lib/src/FlagView.dart.)
  • lib/src/FloatingButtonMenu.dart (Run flutter format to format lib/src/FloatingButtonMenu.dart.)
  • lib/src/MagicListView.dart (Run flutter format to format lib/src/MagicListView.dart.)
  • lib/src/bar/DefaultTabBarBuilder.dart (Run flutter format to format lib/src/bar/DefaultTabBarBuilder.dart.)
  • lib/src/bar/ProgressTapBar.dart (Run flutter format to format lib/src/bar/ProgressTapBar.dart.)
  • lib/src/bar/WidgetTapBar.dart (Run flutter format to format lib/src/bar/WidgetTapBar.dart.)
  • lib/src/decorator/ConnectLineTabIndicator.dart (Run flutter format to format lib/src/decorator/ConnectLineTabIndicator.dart.)
  • lib/src/easy_icon_icons.dart (Run flutter format to format lib/src/easy_icon_icons.dart.)
  • lib/src/easy_stream_builder.dart (Run flutter format to format lib/src/easy_stream_builder.dart.)
  • lib/src/ext/ListViewSeparated.dart (Run flutter format to format lib/src/ext/ListViewSeparated.dart.)
  • lib/src/ext/SliverListSeparatorDelegate.dart (Run flutter format to format lib/src/ext/SliverListSeparatorDelegate.dart.)
  • lib/src/plugin_ext/Rubber.dart (Run flutter format to format lib/src/plugin_ext/Rubber.dart.)
  • lib/src/safe_page.dart (Run flutter format to format lib/src/safe_page.dart.)
  • lib/src/sp/Sp.dart (Run flutter format to format lib/src/sp/Sp.dart.)
  • lib/src/swaper.dart (Run flutter format to format lib/src/swaper.dart.)
  • lib/src/utility.dart (Run flutter format to format lib/src/utility.dart.)
  • lib/src/widget/Papyrus.dart (Run flutter format to format lib/src/widget/Papyrus.dart.)

Maintenance issues and suggestions

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 3 dependencies without version constraints. Specify version ranges for the following dependencies: flutter_swiper, photo_view, rubber.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_swiper any 1.1.6
photo_view any 0.5.0
rubber any 0.4.0
Transitive dependencies
after_layout 1.0.7+2
collection 1.14.11 1.14.12
flutter_page_indicator 0.0.3
meta 1.1.7
sky_engine 0.0.99
transformer_page_view 0.1.6
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies