e_notification_platform_fcm 1.3.1 copy "e_notification_platform_fcm: ^1.3.1" to clipboard
e_notification_platform_fcm: ^1.3.1 copied to clipboard

A new Flutter project.

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

11 out of 16 API elements (68.8 %) have documentation comments.

Some symbols that are missing documentation: e_notification_platform_fcm, e_notification_platform_fcm.ENotificationPlatformFCM, e_notification_platform_fcm.ENotificationPlatformFCM.ENotificationPlatformFCM, e_notification_platform_fcm.ENotificationPlatformFCM.subscriptions, e_notification_platform_fcm.ENotificationPlatformFCM.toENotification.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:e_notification_platform_fcm/e_notification_platform_fcm.dart that imports:
  • package:firebase_messaging/firebase_messaging.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:e_notification_platform_fcm/e_notification_platform_fcm.dart that imports:
  • package:firebase_messaging/firebase_messaging.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:e_notification_platform_fcm/e_notification_platform_fcm.dart that imports:
  • package:firebase_messaging/firebase_messaging.dart that imports:
  • package:firebase_messaging_platform_interface/firebase_messaging_platform_interface.dart that imports:
  • package:firebase_messaging_platform_interface/src/platform_interface/platform_interface_messaging.dart that imports:
  • package:firebase_messaging_platform_interface/src/method_channel/method_channel_messaging.dart that imports:
  • package:firebase_messaging_platform_interface/src/method_channel/utils/exception.dart that imports:
  • package:firebase_core/firebase_core.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/e_notification_platform_fcm.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
e_notification_platform_interface 1.3.1 1.3.1 1.3.1
firebase_core 1.10.0 1.10.0 2.25.4
firebase_messaging 11.1.0 11.1.0 14.7.16
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
firebase_core_platform_interface - 4.8.0 5.0.0
firebase_core_web - 1.7.3 2.11.4
firebase_messaging_platform_interface - 3.5.4 4.5.24
firebase_messaging_web - 2.4.4 3.6.5
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.3 10.0.4
leak_tracker_flutter_testing - 3.0.2 3.0.3
leak_tracker_testing - 3.0.0 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
vector_math - 2.1.4 2.1.4
vm_service - 14.0.0 14.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `1.10.0` on firebase_core does not support the stable version `1.10.1`.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

The constraint `11.1.0` on firebase_messaging does not support the stable version `11.2.0`.

Try running dart pub upgrade --major-versions firebase_messaging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.