dynamic_theme 1.0.1
dynamic_theme: ^1.0.1 copied to clipboard

Changes the theme during runtime, also presists brightness settings across restarts

128
likes
70 / 130
pub points
96 %
popularity

We analyzed this package on May 12, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 26 API elements (23.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:dynamic_theme/dynamic_theme.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: The method 'ancestorStateOfType' isn't defined for the type 'BuildContext'.

lib/dynamic_theme.dart:25:20

   ╷
25 │     return context.ancestorStateOfType(const TypeMatcher<DynamicThemeState>());
   │                    ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/dynamic_theme.dart

INFO: 'TypeMatcher' is deprecated and shouldn't be used. TypeMatcher has been deprecated because it is no longer used in framework(only in deprecated methods). This feature was deprecated after v1.12.1..

lib/dynamic_theme.dart:25:46

   ╷
25 │     return context.ancestorStateOfType(const TypeMatcher<DynamicThemeState>());
   │                                              ^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/dynamic_theme.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
shared_preferences^0.5.00.5.12+42.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.0` on shared_preferences does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions shared_preferences to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=1.20.1 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

128
likes
70
pub points
96%
popularity

Changes the theme during runtime, also presists brightness settings across restarts

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

kozsir.norbert@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, shared_preferences

More

Packages that depend on dynamic_theme