dynamic_tabs 1.1.2
dynamic_tabs: ^1.1.2 copied to clipboard

A Flutter plugin for letting the user edit the bottom tabs like the Cupertino iTunes App.

9
likes
80/ 130
pub points
61%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 148 API elements (8.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:dynamic_tabs/dynamic_tabs.dart that imports:
  • package:dynamic_tabs/ui/more_screen.dart that imports:
  • package:dynamic_tabs/data/models/index.dart that imports:
  • package:dynamic_tabs/data/models/tab_state.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/ui/common/grid_item.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
auto_size_text^3.0.0-nullsafety.03.0.0-nullsafety.03.0.0-nullsafety.0
cupertino_controllers^1.0.2-nullsafety1.1.01.1.0
flutterflutter0.0.00.0.0
shared_preferences^0.5.12+40.5.12+42.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_slidable-0.6.00.6.0
flutter_sticky_header-0.5.00.6.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
shared_preferences_linux-0.0.2+42.0.2
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
value_layout_builder-0.2.00.3.1
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.12+4` on shared_preferences does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions shared_preferences to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • dynamic_tabs that depends on:
  • shared_preferences that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

9
likes
80
pub points
61%
popularity

Publisher

rodydavis.com

A Flutter plugin for letting the user edit the bottom tabs like the Cupertino iTunes App.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

auto_size_text, cupertino_controllers, flutter, shared_preferences

More

Packages that depend on dynamic_tabs