dynamic_list_item 1.3.0 copy "dynamic_list_item: ^1.3.0" to clipboard
dynamic_list_item: ^1.3.0 copied to clipboard

A dynamic list item for who wants default platform styling within Flutter apps.

5
likes
130/ 140
pub points
44%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/sems/dynamic_list_item/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

17 out of 26 API elements (65.4 %) have documentation comments.

Some symbols that are missing documentation: dynamic_list_item, dynamic_list_item.DynamicListItem, dynamic_list_item.DynamicListItem.DynamicListItem, dynamic_list_item.DynamicListItemCallback, dynamic_list_item.DynamicListItemColorTheme.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dynamic_list_item/dynamic_list_item.dart that imports:
  • package:dynamic_list_item/src/dynamic_list_item.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/common/constants.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/common/list_item_position.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

5
likes
130
pub points
44%
popularity

Publisher

verified publishersems.dev

A dynamic list item for who wants default platform styling within Flutter apps.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on dynamic_list_item