dynamic_island 0.0.1 copy "dynamic_island: ^0.0.1" to clipboard
dynamic_island: ^0.0.1 copied to clipboard

A Flutter project for iPhone 14 Pro Max dynamic Island plugin

4
likes
110/ 140
pub points
9%
popularity

We analyzed this package 7 days ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

7 out of 18 API elements (38.9 %) have documentation comments.

Some symbols that are missing documentation: dynamic_island, dynamic_island.DynamicIsland, dynamic_island.DynamicIsland.DynamicIsland, dynamic_island.DynamicIsland.getPlatformVersion, dynamic_island_method_channel.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/dynamic_island.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/dynamic_island_method_channel.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

4
likes
110
pub points
9%
popularity

Publisher

verified publisheranline.cn

A Flutter project for iPhone 14 Pro Max dynamic Island plugin

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, flutter_web_plugins, plugin_platform_interface

More

Packages that depend on dynamic_island