dynamic_forms_comunity 0.0.2

A new flutter plugin project.

0
likes
40 / 110
pub points
0 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 76 API elements (3.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:dynamic_forms_comunity/dynamic_forms_comunity.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:dynamic_forms_comunity/dynamic_forms_comunity.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:dynamic_forms_comunity/dynamic_forms_comunity.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:dynamic_forms_comunity/dynamic_forms_comunity.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: This requires the 'spread-collections' language feature to be enabled.

lib/widgets/dynamic_form.dart:38:15

   ╷
38 │               ...questions.map((item) {
   │               ^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/widgets/dynamic_form.dart

ERROR: This requires the 'spread-collections' language feature to be enabled.

lib/widgets/question_form.dart:110:11

    ╷
110 │           ...question.options.map<DropdownMenuItem>((val) {
    │           ^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/widgets/question_form.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
rxdart^0.22.10.22.60.24.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.22.1` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:13:11

   ╷
13 │   rxdart: ^0.22.1
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
40
pub points
0%
popularity

A new flutter plugin project.

Homepage

Documentation

API reference

Uploader

pabloreinoso0@gmail.com

License

GPL 3.0 (LICENSE)

Dependencies

flutter, rxdart

More

Packages that depend on dynamic_forms_comunity