dynamic_config_generator 0.2.0
dynamic_config_generator: ^0.2.0 copied to clipboard

Dynamically generate config for a build variant using a json file

2
likes
80 / 130
pub points
49 %
popularity

We analyzed this package on Aug 3, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:dynamic_config_generator/dynamic_config_generator.dart that imports:
  • package:dynamic_config_generator/src/config_builder.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build^1.1.61.6.32.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.023.0.0
analyzer-1.7.22.0.0
async-2.8.12.8.1
charcode-1.3.11.3.1
cli_util-0.3.30.3.3
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
glob-2.0.12.0.1
logging-1.0.11.0.1
meta-1.7.01.7.0
package_config-2.0.02.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.6` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

2
likes
80
pub points
49%
popularity

Dynamically generate config for a build variant using a json file

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

build

More

Packages that depend on dynamic_config_generator