dx_shell 1.0.11 copy "dx_shell: ^1.0.11" to clipboard
dx_shell: ^1.0.11 copied to clipboard

A Flutter package that facilitates easy and efficient navigation between pages on Flutter web, while also updating the URL and fixing any incorrect or mistyped search bar entries.

3
likes
120/ 140
pub points
75%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

12 out of 52 API elements (23.1 %) have documentation comments.

Some symbols that are missing documentation: dx_shell, dx_shell.DxNode, dx_shell.DxNode.DxNode, dx_shell.DxNode.name, dx_shell.DxNode.widget.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/controller.dart:1:1

  ╷
1 │ part of dx_shell;
  │ ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controller.dart

INFO: The part-of directive uses a library name.

lib/src/dx_page_view.dart:1:1

  ╷
1 │ part of dx_shell;
  │ ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/dx_page_view.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
autocorrect_and_autocomplete_engine ^0.0.2 0.0.2 0.0.2
flutter flutter 0.0.0 0.0.0
provider ^6.0.0 6.1.2 6.1.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

3
likes
120
pub points
75%
popularity

Publisher

verified publishertaars.site

A Flutter package that facilitates easy and efficient navigation between pages on Flutter web, while also updating the URL and fixing any incorrect or mistyped search bar entries.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

autocorrect_and_autocomplete_engine, flutter, provider

More

Packages that depend on dx_shell