dx_generator 2.0.2 copy "dx_generator: ^2.0.2" to clipboard
dx_generator: ^2.0.2 copied to clipboard

Code generator for dx_router

1
likes
90/ 140
pub points
0%
popularity

We analyzed this package 45 hours ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 18 API elements (5.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: builder, builder.dxRouteBuilder, dx_generator, dx_generator.GenerateDxRoute, dx_generator.GenerateDxRoute.GenerateDxRoute.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The part-of directive uses a library name.

lib/src/library_helpers.dart:1:1

  ╷
1 │ part of DxRouterGenerator;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/library_helpers.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=4.6.0 <6.0.0 5.13.0 6.4.1
ansicolor ^2.0.1 2.0.2 2.0.2
build ^2.3.1 2.4.1 2.4.1
glob ^2.1.1 2.1.2 2.1.2
path ^1.8.2 1.9.0 1.9.0
source_gen ^1.2.6 1.5.0 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 67.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.2 2.3.6
file - 7.0.0 7.0.0
logging - 1.2.0 1.2.0
meta - 1.14.0 1.14.0
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=4.6.0 <6.0.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.