dvote_crypto 0.10.2
dvote_crypto: ^0.10.2 copied to clipboard

Flutter library providing both native and pure Dart implementations of cryptographic primitives

0
likes
80 / 110
pub points
38 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 69 out of 151 API elements (45.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:dvote_crypto/dvote_crypto.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/dart/wallet.dart:35:22

   ╷
35 │   List<int> result = List<int>();
   │                      ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/dart/wallet.dart

lib/native/signature.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bip32^1.0.51.0.71.0.10
bip39^1.0.31.0.31.0.6
convert^2.1.12.1.13.0.0
crypto^2.1.52.1.53.0.1
ffi^0.1.30.1.31.0.0
flutterflutter0.0.00.0.0
hex^0.1.20.1.20.2.0
pinenacl^0.1.20.1.50.2.0
web3dart^2.0.0-dev.72.0.0-dev.92.0.0-dev.9
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
bech32-0.1.20.2.0
bs58check-1.0.11.0.2
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
fixnum-0.10.111.0.0
http-0.12.20.13.1
http_parser-3.1.44.0.0
isolate-2.0.32.0.3
json_rpc_2-2.2.22.2.2
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pointycastle-1.0.23.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^2.1.5` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

0
likes
80
pub points
38%
popularity

Flutter library providing both native and pure Dart implementations of cryptographic primitives

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Uploader

root@dvotelabs.com

License

LGPL 2.1 (LICENSE)

Dependencies

bip32, bip39, convert, crypto, ffi, flutter, hex, pinenacl, web3dart

More

Packages that depend on dvote_crypto