due_date 2.0.0 copy "due_date: ^2.0.0" to clipboard
due_date: ^2.0.0 copied to clipboard

A package for working with repeating DateTime patterns (like the same day every month).

6
likes
130/ 140
pub points
26%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

585 out of 591 API elements (99.0 %) have documentation comments.

Some symbols that are missing documentation: due_date.DateValidatorDifference.retype, due_date.DateValidatorIntersection.retype, due_date.DateValidatorUnion.retype, period.PeriodGenerator.fitsGenerator, period.PeriodGeneratorMixin.fitsGenerator.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection >=1.16.0 <2.0.0 1.18.0 1.18.0
equatable >=2.0.5 <3.0.0 2.0.5 2.0.5
intl >=0.17.0 <0.19.0 0.18.1 0.19.0
time >=2.1.3 <3.0.0 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.17.0 <0.19.0` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

6
likes
130
pub points
26%
popularity

Publisher

unverified uploader

A package for working with repeating DateTime patterns (like the same day every month).

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, equatable, intl, time

More

Packages that depend on due_date