# Globally install the Dart DSA Broker pub global activate -s git https://github.com/IOT-DSA/broker-dart.git
# If you have the pub global executable path setup. dsbroker
# If you do not have the pub global executable path setup. pub global run broker_dart:broker
You can edit the server configuration using
broker.json. For more information about broker configuration, see
Configuring a Broker.
You can install the package from the command line:
$ pub global activate dsbroker
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: dsbroker: ^1.1.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.1.1||Mar 12, 2019|
|1.1.0||Oct 31, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.13.0 <2.0.0|