dryice 2.0.26

Dart native js
Flutter Android iOS web

Lightweight dependency injection framework for Dart.

0
likes
75 / 110
pub points
35 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 2 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/dryice/compare/v2.0...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 39 out of 54 API elements (72.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 100 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/dryice.dart:5:1

  ╷
5 │ /** Lightweight dependency injection framework for Dart. */
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/dryice.dart

INFO: Avoid const keyword.

lib/dryice.dart:42:33

   ╷
42 │ const InjectAnnotation inject = const InjectAnnotation();
   │                                 ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/dryice.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
logging>=0.11.3 <1.0.00.11.40.11.4
reflectable>=2.0.4 <3.0.02.2.52.2.5
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-4.0.010.0.0
analyzer-0.39.100.40.3
args-1.6.01.6.0
async-2.4.22.4.2
build-1.3.01.5.0
build_config-0.4.20.4.2
build_daemon-2.1.42.1.4
build_resolvers-1.3.91.4.1
build_runner_core-5.2.06.0.2
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
code_builder-3.4.13.4.1
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.7
fixnum-0.10.110.10.11
glob-1.2.01.2.0
graphs-0.2.00.2.0
html-0.14.0+30.14.0+3
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
io-0.3.40.3.4
js-0.6.20.6.2
json_annotation-3.1.03.1.0
matcher-0.12.90.12.9
meta-1.2.31.2.3
mime-0.9.70.9.7
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.32.1.3
shelf-0.7.90.7.9
shelf_web_socket-0.2.30.2.3
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
timing-0.1.1+20.1.1+2
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
75
pub points
35%
popularity

Lightweight dependency injection framework for Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

office@mikemitterer.at

License

Apache 2.0 (LICENSE)

Dependencies

logging, reflectable

More

Packages that depend on dryice