drtimport 2.0.0 icon indicating copy to clipboard operation
drtimport: ^2.0.0 copied to clipboard

An cli app to help you refactor you dart libraries because VSCode won't.

2
likes
70/ 130
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 47 out of 224 API elements (21.0 %) have documentation comments.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:drtimport/library.dart that imports:
  • package:drtimport/line.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • dart:cli
Package not compatible with platform iOS

Because:

  • package:drtimport/library.dart that imports:
  • package:drtimport/line.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • dart:cli
Package not compatible with platform Windows

Because:

  • package:drtimport/library.dart that imports:
  • package:drtimport/line.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • dart:cli
Package not compatible with platform Linux

Because:

  • package:drtimport/library.dart that imports:
  • package:drtimport/line.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • dart:cli
Package not compatible with platform macOS

Because:

  • package:drtimport/library.dart that imports:
  • package:drtimport/line.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • dart:cli
Package not compatible with platform Web

Because:

  • package:drtimport/library.dart that imports:
  • package:drtimport/move_result.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

INFO: The import of 'package:path/path.dart' is unnecessary because all of the used elements are also provided by the import of 'package:dcli/dcli.dart'.

lib/line.dart:5:8

  ╷
5 │ import 'package:path/path.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/line.dart

INFO: 'await' applied to 'void', which is not a 'Future'.

lib/make_relative_command.dart:77:5

   ╷
77 │     await process();
   │     ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/make_relative_command.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.6.01.6.02.3.1
dcli^0.28.00.28.01.31.2
file_utils^0.1.30.1.41.0.1
intl^0.16.00.16.10.17.0
logger^0.9.10.9.41.1.0
path^1.6.41.8.21.8.2
pedantic^1.8.01.11.11.11.1
recase^3.0.03.0.14.0.0
yaml^2.2.02.2.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.3.0
async-2.9.02.9.0
basic_utils-2.7.14.2.2
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-2.1.13.0.2
crypto-2.1.53.0.2
csv-4.1.05.0.1
equatable-1.2.62.0.3
file-5.2.16.1.2
glob-1.2.02.1.0
globbing-0.3.11.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.1
ini-2.1.02.1.0
js-0.6.40.6.4
json_annotation-3.1.14.5.0
logging-0.11.41.0.2
matcher-0.12.120.12.12
meta-1.8.01.8.0
money2-1.4.33.1.3
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
pointycastle-2.0.13.6.0
pub_semver-1.4.42.1.1
pubspec-0.1.52.3.0
quiver-2.1.53.1.0
random_string-2.3.12.3.1
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
system_info-0.1.31.0.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uri-0.11.41.0.0
uuid-2.2.23.0.6
validators-2.0.13.0.0
vin_decoder-0.1.4+10.1.4+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^1.6.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.28.0` on dcli does not support the stable version `0.29.0`.

Try running dart pub upgrade --major-versions dcli to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.5.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Dart 2.17.5.

2
likes
70
pub points
0%
popularity

Publisher

verified publisher iconnoojee.dev

An cli app to help you refactor you dart libraries because VSCode won't.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

args, dcli, file_utils, intl, logger, path, pedantic, recase, yaml

More

Packages that depend on drtimport