dropdownfield 1.0.3
dropdownfield: ^1.0.3 copied to clipboard

Flutter Android iOS web

Custom Flutter Widget that mimicks the standard Android auto-complete dropdown field. Has many options for customizing the behavior of this field.

24
likes
100 / 110
pub points
94 %
popularity

We analyzed this package on Jan 20, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 29 API elements (31.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: 'autovalidate' is deprecated and shouldn't be used. Use autoValidateMode parameter which provides more specific behavior related to auto validation. This feature was deprecated after v1.19.0..

lib/dropdownfield.dart:88:11

   ╷
88 │           autovalidate: false,
   │           ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/dropdownfield.dart

INFO: The member 'setState' can only be used within instance members of subclasses of 'package:flutter/src/widgets/framework.dart'.

lib/dropdownfield.dart:103:29

    ╷
103 │                       state.setState(() {
    │                             ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/dropdownfield.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

24
likes
100
pub points
94%
popularity

Custom Flutter Widget that mimicks the standard Android auto-complete dropdown field. Has many options for customizing the behavior of this field.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

cj.androidfreak@gmail.com
jagan.srinivasan@gmail.com

License

BSD (LICENSE)

Dependencies

flutter

More

Packages that depend on dropdownfield