dropdown_suggestions_form_field 1.0.3
dropdown_suggestions_form_field: ^1.0.3 copied to clipboard

The dropdown suggestions form field widget provides a list of suggestions while typing into a text form field

4
likes
90 / 130
pub points
55 %
popularity

We analyzed this package on May 4, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 68 out of 73 API elements (93.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'autovalidate' is deprecated and shouldn't be used. Use autovalidateMode parameter which provide more specific behaviour related to auto validation. This feature was deprecated after v1.19.0..

lib/src/dropdown_suggestions_form_field.dart:493:7

    ╷
493 │       autovalidate: widget.autovalidate,
    │       ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/dropdown_suggestions_form_field.dart

INFO: 'maxLengthEnforced' is deprecated and shouldn't be used. Use maxLengthEnforcement parameter which provides more specific behavior related to the maxLength limit. This feature was deprecated after v1.25.0-5.0.pre..

lib/src/dropdown_suggestions_form_field.dart:509:7

    ╷
509 │       maxLengthEnforced: widget.maxLengthEnforced,
    │       ^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/dropdown_suggestions_form_field.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
rxdart^0.24.00.24.10.26.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.24.0` on rxdart does not support the stable version `0.25.0`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

4
likes
90
pub points
55%
popularity

The dropdown suggestions form field widget provides a list of suggestions while typing into a text form field

Homepage

Documentation

API reference

Uploader

thecloudcomar@gmail.com

License

BSD (LICENSE)

Dependencies

flutter, rxdart

More

Packages that depend on dropdown_suggestions_form_field