dropdown_banner 1.4.0
dropdown_banner: ^1.4.0 copied to clipboard

Manages the creation and animation of banner ui elements that are useful for displaying warnings and updates to users.

56
likes
110 / 110
pub points
79 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 7 API elements (57.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dart_notification_center^1.0.0+11.0.0+11.0.0+1
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

56
likes
110
pub points
79%
popularity

Manages the creation and animation of banner ui elements that are useful for displaying warnings and updates to users.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

flyrboy96@gmail.com

License

MIT (LICENSE)

Dependencies

dart_notification_center, flutter

More

Packages that depend on dropdown_banner