drag_and_drop_flutter 0.3.0 copy "drag_and_drop_flutter: ^0.3.0" to clipboard
drag_and_drop_flutter: ^0.3.0 copied to clipboard

Support native drag and drop of text, files and directories in Flutter.

15
likes
140/ 140
pub points
67%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

61 out of 64 API elements (95.3 %) have documentation comments.

Some symbols that are missing documentation: drag_and_drop_flutter.NullDragAndDropPlatform.registerWith, generated_plugin_registrant, generated_plugin_registrant.registerPlugins.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:drag_and_drop_flutter/drag_and_drop_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:drag_and_drop_flutter/drag_and_drop_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:drag_and_drop_flutter/drag_and_drop_flutter.dart that declares support for platforms: Android, iOS, Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cross_file ^0.3.2 0.3.4+1 0.3.4+1
drag_and_drop_flutter_platform_interface ^0.2.1 0.2.1 0.2.1
drag_and_drop_flutter_web ^0.2.1 0.2.1 0.2.1
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.