dracone 0.1.3
dracone: ^0.1.3 copied to clipboard

Flutter game engine based on fluttershy library and dartex ECS. Currently you can render sprites, rive files (currently without animations) and rectangles.

1
likes
90/ 130
pub points
0%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 230 API elements (0.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dartex^0.1.150.1.150.1.15
flare_flutter^2.0.32.0.63.0.2
flutterflutter0.0.00.0.0
fluttershy^0.1.40.1.40.3.0
ordered_set^2.0.02.0.24.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
flare_dart-2.3.42.3.4
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.0.3` on flare_flutter does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions flare_flutter to update the constraint.

The constraint `^0.1.4` on fluttershy does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions fluttershy to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

1
likes
90
pub points
0%
popularity

Publisher

draconic.dev

Flutter game engine based on fluttershy library and dartex ECS. Currently you can render sprites, rive files (currently without animations) and rectangles.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dartex, flare_flutter, flutter, fluttershy, ordered_set

More

Packages that depend on dracone