dpi_validator 1.0.0 copy "dpi_validator: ^1.0.0" to clipboard
dpi_validator: ^1.0.0 copied to clipboard

A DPI validator. This validate and return values of department and municipality by DPI.

3
likes
130/ 140
pub points
21%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5 out of 6 API elements (83.3 %) have documentation comments.

Some symbols that are missing documentation: dpi_validator.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Dangling library doc comment.

lib/src/check_digit.dart:1:1

  ╷
1 │ ┌ /// Check dpi it's ok following two simples rules, have 13 characters and
2 │ │ ///
3 │ │ /// It require only [dpi] as a param. This will be input to check.
4 │ │ ///
5 │ │ /// ```dart
6 │ │ /// checkDigitByDPI("") === throw "The DPI needs only digits"
7 │ │ /// checkDigitByDPI("1234567890101") == OK, Department: "GUATEMALA", Municipality: "Municipio de Guatemala".
8 │ └ /// ```
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/check_digit.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

3
likes
130
pub points
21%
popularity

Publisher

verified publisherbrandonmanzo.dev

A DPI validator. This validate and return values of department and municipality by DPI.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on dpi_validator