dox_websocket 1.0.0 copy "dox_websocket: ^1.0.0" to clipboard
dox_websocket: ^1.0.0 copied to clipboard

Websocket library for dox framework.

0
likes
130/ 160
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

6 out of 41 API elements (14.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: dox_websocket, dox_websocket.WebsocketAdapterInterface, dox_websocket.WebsocketAdapterInterface.WebsocketAdapterInterface, dox_websocket.WebsocketAdapterInterface.emit, dox_websocket.WebsocketEmitEvent.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dox_websocket/dox_websocket.dart that imports:
  • package:dox_websocket/src/websocket_info.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dox_annotation ^1.0.5 1.0.5 1.0.5
ioredis ^1.0.2 1.0.2 1.0.2
uuid ^3.0.6 3.0.7 4.4.2
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
crypto - 3.0.3 3.0.3
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.6` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.