dox 2.0.1 copy "dox: ^2.0.1" to clipboard
dox: ^2.0.1 copied to clipboard

This is a cli tool to generate migration, model and to handle database migration with dox framework. It support up and down methods to control migration version.

3
likes
140/ 160
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 8 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: dox, dox.createModel, dox.fileGetContents, dox.loadEnv, dox.parseName.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dox/dox.dart that imports:
  • package:dox/src/utils/utils.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dox_migration ^2.0.0 2.0.0 2.0.0
path ^1.8.3 1.9.0 1.9.0
watcher ^1.0.2 1.1.0 1.1.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
buffer - 1.2.3 1.2.3
charcode - 1.3.1 1.3.1
collection - 1.19.0 1.19.0
crypto - 3.0.3 3.0.3
meta - 1.15.0 1.15.0
pool - 1.5.1 1.5.1
postgres - 3.2.1 3.2.1
sasl_scram - 0.1.1 0.1.1
saslprep - 1.0.3 1.0.3
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
typed_data - 1.3.2 1.3.2
unorm_dart - 0.3.0 0.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

3
likes
140
pub points
0%
popularity

Publisher

verified publisherdartondox.dev

This is a cli tool to generate migration, model and to handle database migration with dox framework. It support up and down methods to control migration version.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

dox_migration, path, watcher

More

Packages that depend on dox