dotup_flutter_logger_sqflite_writer 0.2.0
dotup_flutter_logger_sqflite_writer: ^0.2.0 copied to clipboard

SqfLite log writer for https://github.com/dotupNET/dotup_dart_logger

0
likes
70/ 130
pub points
20%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/dotupNET/dotup_flutter_logger_sqflite_writer was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 28 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:dotup_flutter_logger_sqflite_writer/dotup_flutter_logger_sqflite_writer.dart that imports:
  • package:dotup_flutter_logger_sqflite_writer/src/database/LoggerEntity.dart that imports:
  • package:dotup_flutter_logger_sqflite_writer/src/database/Entity.dart that imports:
  • package:dotup_flutter_logger_sqflite_writer/src/database/SQLite/SqLiteRepository.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

lib/src/LoggerMapper.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/LoggerRepository.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dotup_dart_logger^0.2.00.2.00.6.0
flutterflutter0.0.00.0.0
sqflite^2.0.0+32.0.0+42.0.0+4
sqflite_common^2.0.0+22.0.1+12.0.1+1
sqflite_common_ffi^2.0.0+12.0.0+32.0.0+3
uuid^3.0.43.0.53.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.1.21.1.2
meta-1.7.01.7.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
sqlite3-1.2.01.2.0
synchronized-3.0.03.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.0` on dotup_dart_logger does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions dotup_dart_logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
70
pub points
20%
popularity

Publisher

dotup.de

SqfLite log writer for https://github.com/dotupNET/dotup_dart_logger

Homepage
Repository (missing)
View/report issues

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

dotup_dart_logger, flutter, sqflite, sqflite_common, sqflite_common_ffi, uuid

More

Packages that depend on dotup_flutter_logger_sqflite_writer