docx_mailmerge 1.0.2+1 icon indicating copy to clipboard operation
docx_mailmerge: ^1.0.2+1 copied to clipboard

Package for performing a mailmerge operation on merge fields within a DOCX document

3
likes
110/ 130
pub points
30%
popularity

We analyzed this package 2 hours ago, and awarded it 110 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 9 API elements (88.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/src/constants.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/docx_mailmerge_base.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^3.1.63.3.03.3.0
shlex^2.0.22.0.22.0.2
xml^5.3.15.4.16.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.16.01.16.0
crypto-3.0.23.0.2
meta-1.7.01.7.0
path-1.8.11.8.1
petitparser-5.0.05.0.0
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.3.1` on xml does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions xml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Dart 2.17.0.

3
likes
110
pub points
30%
popularity

Publisher

unverified uploader

Package for performing a mailmerge operation on merge fields within a DOCX document

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

archive, shlex, xml

More

Packages that depend on docx_mailmerge