document_provider 0.0.1
document_provider: ^0.0.1

Flutter Android iOS

A new Flutter plugin.

0
likes
70 / 100
pub points
20 %
popularity

We analyzed this package on Nov 16, 2020, and awarded it 70 pub points (of a possible 100):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/lib/main.dart
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:document_provider/document_provider.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:document_provider/document_provider.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:document_provider/document_provider.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:document_provider/document_provider.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/document_provider.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.5
collection-1.15.0-nullsafety.31.15.0-nullsafety.5
meta-1.3.0-nullsafety.31.3.0-nullsafety.6
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs