dmake 0.0.3
dmake: ^0.0.3

Dart native
Flutter Android iOS

Simple, flexible build system in Dart. Inspired by CMake and GNU Make.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 25 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dmake/dmake.dart that imports:
  • package:dmake/src/top_level.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 30 issues. Showing the first 2:

INFO: Unnecessary new keyword.

bin/dmake.dart:8:17

  ╷
8 │ var argParser = new ArgParser()
  │                 ^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/dmake.dart

INFO: Unnecessary new keyword.

bin/dmake.dart:31:16

   ╷
31 │     if (!await new File(filename).exists()) {
   │                ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/dmake.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.0.01.6.01.6.0
glob^1.0.01.2.01.2.0
graphs^0.1.20.1.3+10.2.0
io^0.3.20.3.40.3.4
logging^0.11.00.11.40.11.4
mime^0.9.60.9.70.9.7
path^1.0.01.7.01.7.0
rxdart^0.19.00.19.00.24.1
watcher^0.9.70.9.7+150.9.7+15
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
charcode-1.1.31.1.3
collection-1.14.131.14.13
file-5.2.15.2.1
intl-0.16.10.16.1
js-0.6.20.6.2
meta-1.2.41.2.4
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
pedantic-1.9.21.9.2
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.2` on graphs does not support the latest published version `0.2.0`

pubspec.yaml:11:11

   ╷
11 │   graphs: ^0.1.2
   │           ^^^^^^
   ╵
The constraint `^0.19.0` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:16:11

   ╷
16 │   rxdart: ^0.19.0
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

Simple, flexible build system in Dart. Inspired by CMake and GNU Make.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

thosakwe@gmail.com

License

MIT (LICENSE)

Dependencies

args, glob, graphs, io, logging, mime, path, rxdart, watcher

More

Packages that depend on dmake