dive_obslib 0.5.0 copy "dive_obslib: ^0.5.0" to clipboard
dive_obslib: ^0.5.0 copied to clipboard

PlatformmacOS

A Flutter plugin package for Dive that provides low level access to obslib using FFI.

2
likes
130/ 140
pub points
16%
popularity

We analyzed this package 5 hours ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://divekit.dev was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

55 out of 118 API elements (46.6 %) have documentation comments.

Some symbols that are missing documentation: dive_obslib, dive_obslib.DiveBaseObslib, dive_obslib.DiveBaseObslib.DiveBaseObslib, dive_obslib.DiveFFIObslib.audioSetDefaultMonitoringDevice, dive_obslib.DiveFFIObslib.createImageSource.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:dive_obslib/dive_obslib.dart that declares support for platforms: macOS.
Package does not support platform `iOS`.

Because:

  • package:dive_obslib/dive_obslib.dart that declares support for platforms: macOS.
Package does not support platform `Windows`.

Because:

  • package:dive_obslib/dive_obslib.dart that declares support for platforms: macOS.
Package does not support platform `Linux`.

Because:

  • package:dive_obslib/dive_obslib.dart that declares support for platforms: macOS.
Package does not support platform `Web`.

Because:

  • package:dive_obslib/dive_obslib.dart that declares support for platforms: macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: An uninitialized variable should have an explicit type annotation.

lib/src/dive_ffi_obslib.dart:73:9

   ╷
73 │     var msg;
   │         ^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/dive_ffi_obslib.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/dive_ffi_obslib.dart:484:7

    ╷
484 │       state = 1;
    │       ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/dive_ffi_obslib.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.1 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

2
likes
130
pub points
16%
popularity

Publisher

verified publisherlarryaasen.com

A Flutter plugin package for Dive that provides low level access to obslib using FFI.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, flutter

More

Packages that depend on dive_obslib