dgg_pullrefresh 0.0.2
dgg_pullrefresh: ^0.0.2

Flutter Android iOS web

A new Flutter package project using pull refresh in iOS and Android.

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 330 out of 680 API elements (48.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: Unused import: 'package:dgg_pullrefresh/pull_refresh/screenutil.dart'.

lib/pull_refresh/flutter_pull_refresh.dart:2:8

  ╷
2 │ import 'package:dgg_pullrefresh/pull_refresh/screenutil.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/pull_refresh/flutter_pull_refresh.dart

INFO: 'overflow' is deprecated and shouldn't be used. Use clipBehavior instead. See the migration guide in flutter.dev/go/clip-behavior. This feature was deprecated after v1.22.0-12.0.pre..

lib/pull_refresh/src/indicator/bezier_indicator.dart:147:11

    ╷
147 │           overflow: Overflow.visible,
    │           ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/pull_refresh/src/indicator/bezier_indicator.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
0%
popularity

A new Flutter package project using pull refresh in iOS and Android.

Homepage

Documentation

API reference

Uploader

wmp505490956@gmail.com

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on dgg_pullrefresh