device_region 1.0.1 icon indicating copy to clipboard operation
device_region: ^1.0.1 copied to clipboard

This plugin uses platform-specific API to return SIM country code

11
likes
140/ 140
pub points
76%
popularity

We analyzed this package 21 hours ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 4 API elements (25.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:device_region/device_region.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:device_region/device_region.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:device_region/device_region.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:device_region/device_region.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.17.1 1.17.2
js - 0.6.7 0.6.7
material_color_utilities - 0.2.0 0.5.0
meta - 1.9.1 1.9.1
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Dart 3 & Flutter 3.10 compatibility
20 / 20icon to trigger folding of the section

20/20 points: Package is Dart 3 & Flutter 3.10 compatible!

Analysed with Pana 0.21.32, Flutter 3.10.2, Dart 3.0.2.

11
likes
140
pub points
76%
popularity

Publisher

verified publisher iconmatszafraniec.xyz

This plugin uses platform-specific API to return SIM country code

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on device_region