device_id 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 47

device_id #

A Flutter plugin for retrieving the uid of a device

Getting Started #

To retrieve the id just import and call String device_id = await DeviceId.getID;. Now you are good to go!

0.1.0 #

Added functions

0.1.1 #

Bug fix

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:device_id/device_id.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _deviceid = 'Unknown';

  @override
  void initState() {
    super.initState();
    initDeviceId();
  }

  Future<void> initDeviceId() async {
    String deviceid;

    deviceid = await DeviceId.getID;

    if (!mounted) return;

    setState(() {
      _deviceid = deviceid;
    });
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Device Id example app'),
        ),
        body: new Center(
          child: new Text('Your device id: $_deviceid'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  device_id: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:device_id/device_id.dart';
  
Version Uploaded Documentation Archive
0.2.0 Apr 11, 2019 Go to the documentation of device_id 0.2.0 Download device_id 0.2.0 archive
0.1.3 Sep 17, 2018 Go to the documentation of device_id 0.1.3 Download device_id 0.1.3 archive
0.1.2 Aug 17, 2018 Go to the documentation of device_id 0.1.2 Download device_id 0.1.2 archive
0.1.1 Jul 7, 2018 Go to the documentation of device_id 0.1.1 Download device_id 0.1.1 archive
0.1.0 Jul 7, 2018 Go to the documentation of device_id 0.1.0 Download device_id 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
94
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0