dev 0.0.2

Flutter Android iOS web

Dev tools and widgets for Flutter applications.

0
likes
90 / 110
pub points
45 %
popularity

We analyzed this package on Sep 23, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 19 API elements (21.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
gestures^0.0.10.0.10.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
45%
popularity

Publisher

andrebaltazar.com

Dev tools and widgets for Flutter applications.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, gestures

More

Packages that depend on dev