detect_proxy_setting 0.0.6 icon indicating copy to clipboard operation
detect_proxy_setting: ^0.0.6 copied to clipboard

This package detect proxy setting for http. Supported os are Android, iOS, MacOS, Windows.

0
likes
120/ 140
pub points
64%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:detect_proxy_setting/detect_proxy_setting.dart that declares support for platforms: Android, iOS, Windows, macOS.
Package does not support platform `Web`.

Because:

  • package:detect_proxy_setting/detect_proxy_setting.dart that declares support for platforms: Android, iOS, Windows, macOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
proxy_setting_android^0.0.50.0.50.0.5
proxy_setting_ios^0.0.30.0.30.0.3
proxy_setting_macos^0.0.40.0.40.0.4
proxy_setting_platform_interface^0.0.30.0.30.0.3
proxy_setting_windows^0.0.40.0.40.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.