demo_0518_2 1.0.0+1

  • Readme
  • Changelog
  • Installing
  • 43

[toc]

demo_0518_2 #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

MethodChannel #

flutter 调 native #

Dart实现 #

  1. 定义特定的MethodChannel,标识为“com.sicilyliu”
  2. 定义点击触发的Future方法,里面调用的MethodChannel.invokeMethod

swift实现 #

  1. 初始化FlutterViewController,FlutterMethodChannel
  2. 定义methodChannel.setMethodCallHandler,里面根据调过来的方法名和参数做相应处理

native 调 flutter #

swift实现 #

  1. 初始化FlutterViewController,FlutterMethodChannel
  2. 调用methodChannel.invokeMethod,传参方法名和参数

Dart代码 #

  1. 唤醒监听nativeMessageListener(),可以放在initState()里面
  2. 定义监听处理nativeMessageListener()的Future方法,根据调过来的方法名和参数做处理

1.0.0+1 #

2020-05-21 #

Other Changes #

  • readme

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  demo_0518_2: ^1.0.0+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:demo_0518_2/demo_0518_2.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [demo_0518_2] that is in a package requiring null.

Health suggestions

Fix lib/demo_0518_2.dart. (-2.48 points)

Analysis of lib/demo_0518_2.dart reported 5 hints:

line 38 col 8: The declaration '_incrementCounter' isn't referenced.

line 45 col 9: The value of the local variable '_message' isn't used.

line 54 col 48: This function has a return type of 'Future

line 68 col 8: This method overrides a method annotated as '@mustCallSuper' in 'State', but doesn't invoke the overridden method.

line 86 col 48: 'display1' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline4. This feature was deprecated after v1.13.8..

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and demo_0518_2.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
cupertino_icons ^0.1.3 0.1.3
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test