defichaindart 3.8.3 icon indicating copy to clipboard operation
defichaindart: ^3.8.3 copied to clipboard

A dart DefiChain library for Flutter. BIP32, BIP39, P2PKH integration.

3
likes
100/ 130
pub points
67%
popularity

We analyzed this package 26 hours ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 281 API elements (0.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:defichaindart/defichaindart.dart that imports:
  • package:defichaindart/src/payments/p2sh.dart that imports:
  • package:defichaindart/src/utils/script.dart that imports:
  • package:bip32_defichain/src/utils/ecurve.dart that imports:
  • dart:ffi
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

lib/src/address.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/bip39/bip39_base.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bip32_defichain^3.0.1+13.0.1+13.0.1+1
bs58check^1.0.21.0.21.0.2
collection^1.15.01.15.01.15.0
convert^3.0.13.0.13.0.1
crypto^3.0.13.0.13.0.1
defichain_bech32^0.1.00.1.00.1.0
hex^0.2.00.2.00.2.0
meta^1.3.01.7.01.7.0
pointycastle^3.3.43.5.03.5.0
Transitive dependencies
PackageConstraintCompatibleLatest
js-0.6.30.6.4
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.5, Dart 2.15.1.