deact_router 0.1.0 copy "deact_router: ^0.1.0" to clipboard
deact_router: ^0.1.0 copied to clipboard

Platformweb

An client-side router for deact

1
likes
120/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 7 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: deact_router, deact_router.changeTitle, deact_router.getNext, deact_router.goto, deact_router.linkTo.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:deact_router/deact_router.dart that imports:
  • package:deact_router/src/router.dart that imports:
  • package:deact/deact_html52.dart that imports:
  • package:deact/deact.dart that imports:
  • package:domino/browser.dart that imports:
  • package:domino/src/browser_impl.dart that imports:
  • dart:html
Package not compatible with platform iOS

Because:

  • package:deact_router/deact_router.dart that imports:
  • package:deact_router/src/router.dart that imports:
  • package:deact/deact_html52.dart that imports:
  • package:deact/deact.dart that imports:
  • package:domino/browser.dart that imports:
  • package:domino/src/browser_impl.dart that imports:
  • dart:html
Package not compatible with platform Windows

Because:

  • package:deact_router/deact_router.dart that imports:
  • package:deact_router/src/router.dart that imports:
  • package:deact/deact_html52.dart that imports:
  • package:deact/deact.dart that imports:
  • package:domino/browser.dart that imports:
  • package:domino/src/browser_impl.dart that imports:
  • dart:html
Package not compatible with platform Linux

Because:

  • package:deact_router/deact_router.dart that imports:
  • package:deact_router/src/router.dart that imports:
  • package:deact/deact_html52.dart that imports:
  • package:deact/deact.dart that imports:
  • package:domino/browser.dart that imports:
  • package:domino/src/browser_impl.dart that imports:
  • dart:html
Package not compatible with platform macOS

Because:

  • package:deact_router/deact_router.dart that imports:
  • package:deact_router/src/router.dart that imports:
  • package:deact/deact_html52.dart that imports:
  • package:deact/deact.dart that imports:
  • package:domino/browser.dart that imports:
  • package:domino/src/browser_impl.dart that imports:
  • dart:html
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
deact ^1.0.0 1.5.2 1.5.2
Transitive dependencies
Package Constraint Compatible Latest
domino - 0.8.4 0.8.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.