ddi 0.1.1

Dart Dependency Injection #

Getting Started

1/ Binding:

class TestModule extends AbstractModule {
    @override
    void init() {
	    bind(String).to("A String Instance");
	    bind(int).to(404);
	    bind(TestClass).to(new TestClass(this.get(String)));
	    bind("AnotherTestClass").to(new TestClass("AnotherTestClass"));
    }
}

2/ Use your DI

void main() {
    DI.init([new TestModule()]);
    String str = DI.get(String);
    expect(str, equals("A String Instance"));
}

[0.1.0] - First release

  • TODO: Simple DI for flutter/dart

example/main.dart

import 'package:ddi/di.dart';
import 'package:ddi/module.dart';

import 'logger.dart';

void main(List<String> args) {
  DI.init([new ExampleModule()]);

  Logger logger = DI.get(Logger);
  logger.debug("Hello Dart Dependency Injection");  
  var logger2 = DI.get<Logger>(Logger);
  logger2.debug("Hello Dart Dependency Injection");
}

class ExampleModule extends AbstractModule{
  @override
  void init() {
    bind(Logger).to(new ConsoleLogger());
  }
  
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ddi: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ddi/di.dart';
import 'package:ddi/injector.dart';
import 'package:ddi/module.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
24
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test