dd_base 0.0.13 icon indicating copy to clipboard operation
dd_base: ^0.0.13 copied to clipboard

A Flutter package with dd_base, .

0
likes
70/ 140
pub points
0%
popularity

We analyzed this package 8 hours ago, and awarded it 70 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 142 API elements (7.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:dd_base/dd_base.dart that imports:
  • package:flustars/flustars.dart that imports:
  • package:flustars/src/directory_util.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:dd_base/dd_base.dart that imports:
  • package:flustars/flustars.dart that imports:
  • package:flustars/src/directory_util.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:dd_base/dd_base.dart that imports:
  • package:flustars/flustars.dart that imports:
  • package:flustars/src/directory_util.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: The import of 'package:flutter/foundation.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/cupertino.dart'.

lib/dd_base.dart:5:8

  ╷
5 │ import 'package:flutter/foundation.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/dd_base.dart

INFO: The import of 'package:flutter/material.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/cupertino.dart'.

lib/dd_base.dart:7:8

  ╷
7 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/dd_base.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
artemis>=5.0.0 <6.0.05.1.06.18.4
flustars>=0.0.1 <1.0.00.3.32.0.1
flutterflutter0.0.00.0.0
gql>=0.7.3 <1.0.00.12.40.14.0
gql_http_link>=0.0.1 <1.0.00.2.70.4.5
http>=0.0.1 <1.0.00.12.20.13.5
json_annotation>=3.0.0 <4.0.03.1.14.8.0
meta>=1.0.0 <2.0.01.8.01.9.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.052.0.0
analyzer-0.41.25.4.0
args-2.3.22.3.2
async-2.10.02.10.0
build-1.6.22.3.1
build_config-0.4.71.1.1
built_collection-5.1.15.1.1
built_value-8.4.38.4.3
characters-1.2.11.2.1
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.2
cli_util-0.3.50.3.5
clock-1.1.11.1.1
code_builder-3.7.04.4.0
collection-1.17.01.17.1
common_utils-2.1.02.1.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
dart_style-1.3.122.2.4
decimal-2.3.22.3.2
equatable-1.2.62.0.5
file-5.2.16.1.4
fixnum-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
glob-1.2.12.1.1
gql_code_gen-0.1.50.1.5
gql_dedupe_link-1.0.92.0.3+1
gql_exec-0.2.50.4.3
gql_link-0.2.30.5.1
http_parser-3.1.44.0.2
intl-0.18.00.18.0
js-0.6.50.6.7
logging-1.1.11.1.1
matcher-0.12.140.12.14
material_color_utilities-0.2.00.2.0
node_interop-1.2.12.1.0
node_io-1.2.02.2.0
package_config-1.9.32.1.0
path-1.8.31.8.3
path_provider-1.6.92.0.12
path_provider_macos-0.0.4+82.0.7
path_provider_platform_interface-1.0.42.0.5
pedantic-1.11.11.11.1
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.3
pub_semver-2.1.32.1.3
pubspec_parse-0.1.81.2.1
rational-2.2.22.2.2
recase-2.0.14.1.0
shared_preferences-0.5.7+32.0.17
shared_preferences_macos-0.0.1+112.0.5
shared_preferences_platform_interface-1.0.42.1.0
shared_preferences_web-0.1.2+72.0.4
sky_engine-0.0.990.0.99
source_gen-0.9.10+31.2.7
source_span-1.9.11.9.1
sp_util-1.0.22.0.3
stack_trace-1.11.01.11.0
string_scanner-1.2.01.2.0
synchronized-3.0.13.0.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=5.0.0 <6.0.0` on artemis does not support the stable version `6.17.1`.

Try running dart pub upgrade --major-versions artemis to update the constraint.

The constraint `>=0.0.1 <1.0.0` on flustars does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flustars to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

0
likes
70
pub points
0%
popularity

Publisher

unverified uploader

A Flutter package with dd_base, .

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

artemis, flustars, flutter, gql, gql_http_link, http, json_annotation, meta

More

Packages that depend on dd_base