dct 0.0.4
dct: ^0.0.4 copied to clipboard

package runner for dart

0
likes
60/ 130
pub points
0%
popularity

We analyzed this package on Oct 26, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://git.avalon.infra.lavacast.net/tooling/dct was unreachable.

Repository URL doesn't exist.

At the time of the analysis https://git.avalon.infra.lavacast.net/tooling/dct was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dct/download.dart that imports:
  • package:cli_util/cli_logging.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.132.0.133.1.6
args^1.6.01.6.02.3.0
cli_util^0.2.00.2.00.3.5
http^0.12.10.12.20.13.4
path^1.7.01.8.01.8.0
platform_info^1.1.1+31.1.1+33.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
http_parser-3.1.44.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^2.0.13` on archive does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions archive to update the constraint.

The constraint `^1.6.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.1 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
60
pub points
0%
popularity

Publisher

lavacast.net

package runner for dart

Repository (missing)

Documentation

API reference

License

MPL-2.0 (LICENSE)

Dependencies

archive, args, cli_util, http, path, platform_info

More

Packages that depend on dct