dcoupon_sdk_flutter_package 1.1.3

Flutter Android iOS

dcoupon sdk flutter plugin project. Support flutter (Android/iOS) applications to integrate dcoupon web services for flutter projects.

1
likes
80 / 110
pub points
33 %
popularity

We analyzed this package on Oct 19, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 27 out of 47 API elements (57.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:dcoupon_sdk_flutter_package/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/injection_container.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:dcoupon_sdk_flutter_package/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/injection_container.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web
Package does not support Flutter platform Linux

Because:

  • package:dcoupon_sdk_flutter_package/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/injection_container.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform macOS

Because:

  • package:dcoupon_sdk_flutter_package/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/injection_container.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:dcoupon_sdk_flutter_package/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/injection_container.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:dcoupon_sdk_flutter_package/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/dcoupon_sdk_flutter_package.dart that imports:
  • package:dcoupon_sdk_flutter_package/src/injection_container.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/data/datasources/coupon_remote_data_sources.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/data/datasources/promotion_remote_data_source.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.1.32.1.52.1.5
cupertino_icons^1.0.01.0.01.0.0
dartz^0.9.10.9.20.9.2
dio^3.0.103.0.103.0.10
equatable^1.2.51.2.51.2.5
flutterflutter0.0.00.0.0
flutter_datetime_picker^1.2.51.4.01.4.0
flutter_html^1.0.21.0.21.0.2
flutter_localizationsflutter0.0.00.0.0
get_it^4.0.44.0.45.0.1
html_unescape^1.0.1+31.0.21.0.2
intl^0.16.00.16.10.16.1
meta^1.1.81.3.0-nullsafety.31.3.0-nullsafety.4
ntp^1.0.71.0.71.0.7
shared_preferences^0.5.120.5.12+20.5.12+2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.5.0-nullsafety.1
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
chewie-0.9.100.9.10
chewie_audio-1.0.0+11.0.0+1
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
convert-2.1.12.1.1
css_colors-1.0.21.0.2
csslib-0.16.20.16.2
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_svg-0.18.10.19.1
flutter_web_plugins-0.0.00.0.0
html-0.14.0+40.14.0+4
http_parser-3.1.43.1.4
open_iconic_flutter-0.3.00.3.0
path-1.8.0-nullsafety.11.8.0-nullsafety.1
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
screen-0.0.50.0.5
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.2
string_scanner-1.0.51.1.0-nullsafety.1
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
universal_io-1.0.11.0.1
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3
video_player-0.10.12+50.11.1+2
video_player_platform_interface-2.2.02.2.0
video_player_web-0.1.40.1.4
wakelock-0.1.4+20.2.0+1
webview_flutter-0.3.241.0.3
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2
xml-4.5.14.5.1
zone_local-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.4` on get_it does not support the latest published version `5.0.1`

pubspec.yaml:29:11

   ╷
29 │   get_it: ^4.0.4
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
80
pub points
33%
popularity

Publisher

dcoupon.com

dcoupon sdk flutter plugin project. Support flutter (Android/iOS) applications to integrate dcoupon web services for flutter projects.

Homepage

Documentation

API reference

License

BSD (LICENSE)

Dependencies

crypto, cupertino_icons, dartz, dio, equatable, flutter, flutter_datetime_picker, flutter_html, flutter_localizations, get_it, html_unescape, intl, meta, ntp, shared_preferences

More

Packages that depend on dcoupon_sdk_flutter_package