dcoupon_sdk_flutter_module 0.0.1

  • Readme
  • Changelog
  • Installing
  • 32

dcoupon_sdk_flutter_module #

A new flutter module project.

Getting Started #

For help getting started with Flutter, view our online documentation.

0.0.1 #

  • Published public API for 3rdParty

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dcoupon_sdk_flutter_module: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dcoupon_sdk_flutter_module/constants.dart';
import 'package:dcoupon_sdk_flutter_module/enrollmentformview.dart';
import 'package:dcoupon_sdk_flutter_module/httprequest.dart';
import 'package:dcoupon_sdk_flutter_module/httpservice.dart';
import 'package:dcoupon_sdk_flutter_module/main.dart';
import 'package:dcoupon_sdk_flutter_module/services.dart';
import 'package:dcoupon_sdk_flutter_module/translations.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Health issues and suggestions

Fix lib/enrollmentformview.dart. (-25 points)

Analysis of lib/enrollmentformview.dart failed with 1 error:

line 67 col 44: The getter 'cachedLocaleString' isn't defined for the type 'Locale'.

Format lib/httprequest.dart.

Run flutter format to format lib/httprequest.dart.

Format lib/httpservice.dart.

Run flutter format to format lib/httpservice.dart.

Format lib/services.dart.

Run flutter format to format lib/services.dart.

Format lib/translations.dart.

Run flutter format to format lib/translations.dart.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (flutter_html).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dcoupon_sdk_flutter_module.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
crypto ^2.1.3 2.1.5
cupertino_icons ^0.1.2 0.1.3
flutter 0.0.0
flutter_cupertino_date_picker ^1.0.12 1.0.26+2
flutter_datetime_picker ^1.2.5 1.3.8
flutter_html ^0.11.0 0.11.1 1.0.0
flutter_localizations 0.0.0
html_unescape ^1.0.1+3 1.0.1+3
intl ^0.16.0 0.16.1
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
csslib 0.16.1
html 0.14.0+3
meta 1.1.8 1.2.2
path 1.6.4 1.7.0
sky_engine 0.0.99
source_span 1.7.0
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies