dconf 0.1.0
dconf: ^0.1.0 copied to clipboard

dconf is a simple package which allow to retrieve, parse and manage configuration is the most agnostic way possible.

0
likes
80 / 130
pub points
0 %
popularity

We analyzed this package on May 4, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 31 API elements (12.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dconf/dconf.dart that imports:
  • package:dconf/src/io_loader.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.111.15.01.15.0
path^1.6.21.8.01.8.0
yaml^2.1.152.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.15` on yaml does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
80
pub points
0%
popularity

dconf is a simple package which allow to retrieve, parse and manage configuration is the most agnostic way possible.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

platel.kevin@gmail.com

License

MIT (LICENSE)

Dependencies

collection, path, yaml

More

Packages that depend on dconf