db_construction_site 0.0.1-dev+1
db_construction_site: ^0.0.1-dev+1 copied to clipboard

Unofficial Dart implementation of Deutsche Bahn's construction site API

0
likes
90/ 130
pub points
0%
popularity

We analyzed this package on Oct 26, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://git.jfdev.de/JonasFranzDEV/db_construction_site was unreachable.

Repository URL doesn't exist.

At the time of the analysis https://git.jfdev.de/JonasFranzDEV/db_construction_site was unreachable.

Issue tracker URL doesn't exist.

At the time of the analysis https://git.jfdev.de/JonasFranzDEV/db_construction_site/issues was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 24 API elements (66.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.20.12.20.13.4
json_annotation^3.0.13.1.14.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^3.0.1` on json_annotation does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
90
pub points
0%
popularity

Publisher

jonasfranz.de

Unofficial Dart implementation of Deutsche Bahn's construction site API

Repository (missing)
View/report issues (missing)

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http, json_annotation

More

Packages that depend on db_construction_site