date_time 0.10.0 copy "date_time: ^0.10.0" to clipboard
date_time: ^0.10.0 copied to clipboard

Package to work with Date & Time in separation and with its Ranges.

16
likes
110/ 140
pub points
85%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

391 out of 441 API elements (88.7 %) have documentation comments.

Some symbols that are missing documentation: date_time, date_time.Date.asDateTime, date_time.Date.asUtcDateTime, date_time.Date.copyWith, date_time.Date.Date.from.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/time_range.dart:65:17

   ╷
65 │   bool operator ==(dynamic other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/time_range.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/month.dart:137:7

    ╷
137 │       throw RangeError.range(day, 1, endOfMonth.day);
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/month.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
clock ^1.1.1 1.1.1 1.1.1
intl ^0.18.0 0.18.1 0.19.0
json_annotation ^4.8.1 4.8.1 4.8.1
quiver ^3.2.1 3.2.1 3.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
collection - 1.18.0 1.18.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.0` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

16
likes
110
pub points
85%
popularity

Publisher

verified publisherdevcraft.ninja

Package to work with Date & Time in separation and with its Ranges.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

clock, intl, json_annotation, quiver

More

Packages that depend on date_time